LAMP一键安装包
LAMP

LAMP 一键安装包是一个用 Linux Shell 编写的可以为 Amazon Linux/CentOS/Debian/Ubuntu 系统的 VPS 或服务器安装 LAMP(Linux + Apache + MySQL/MariaDB + PHP) 生产环境的 Shell 脚本。包含一些可选安装组件如:
Zend OPcacheionCube LoaderPDFlibXCacheAPCuimagickgmagicklibsodiummemcachedredismongodbswooleyafyarmsgpackpsrphalcongrpcxdebug

其他诸如:OpenSSLImageMagickGraphicsMagickMemcachedphpMyAdminAdminerRedisre2cKodExplorer

同时还有一些辅助脚本如:虚拟主机管理、Apache、MySQL/MariaDB、PHP 及 PhpMyAdmin、Adminer 的升级等。

为什么需要LAMP?

手动逐个编译安装各个组件,需要输入各种命令,且有可能会中途出错。
对于想要成功搭建 LAMP 建站环境来说,可以节约大量时间和精力。

LAMP 有什么优点?

LAMP 是最经典的建站环境之一,风靡世界十几年。
而本脚本只需几个简单交互,选择需要安装的包,即可一路安装,无人值守。

本脚本默认支持 PHP 探针所标识的所有 PHP 组件,截图如下:

英文版 PHP 探针所标识的所有 PHP 组件,截图如下:

如何获取

通过本站下载页面,你可以使用它在 VPS 或独立服务器上安装。
也可以在安装页面,按照步骤说明直接安装。

交互安装

系统需求

  • 系统支持

Amazon Linux 2018.03
Amazon Linux 2
CentOS-6.x
CentOS-7.x
CentOS-8.x (recommend)
Debian-8.x
Debian-9.x
Debian-10.x (recommend)
Ubuntu-16.x
Ubuntu-18.x
Ubuntu-20.x (recommend)

  • 内存要求:≥ 512MB
  • 硬盘要求:至少 10GB 以上的剩余空间
  • 服务器必须配置好 软件源 和 可连接外网
  • 必须具有系统 root 权限
  • 强烈建议使用全新系统来安装

支持组件

  • 支持 PHP 自带几乎所有组件
  • 支持 SQLite、MySQL、MariaDB 数据库
  • 支持 Yaf(可选安装)
  • 支持 Redis(可选安装)
  • 支持 XCache (可选安装)
  • 支持 Swoole (可选安装)
  • 支持 Memcached (可选安装)
  • 支持 ImageMagick (可选安装)
  • 支持 GraphicsMagick (可选安装)
  • 支持 ionCube Loader (可选安装)
  • 自助升级 Apache,PHP,phpMyAdmin,Adminer,MySQL/MariaDB 至最新版本
  • 命令行新增虚拟主机(使用 lamp 命令),操作简便
  • 支持一键卸载程序(不会删除网站数据)

安装步骤

  1. 事前准备(安装 wget、git)

注意:双斜杠//后的内容不要复制输入

yum -y install wget git      // for Amazon Linux/CentOS
apt-get -y install wget git  // for Debian/Ubuntu
  1. git clone 并赋予脚本执行权限
git clone https://github.com/teddysun/lamp.git
cd lamp
chmod 755 *.sh
  1. 开始安装
./lamp.sh

组件安装

关于本脚本支持的所有组件,都可以在脚本交互里可选安装。

使用提示

lamp add      创建虚拟主机
lamp del      删除虚拟主机
lamp list     列出虚拟主机
lamp version  显示当前版本

如何升级

注意:双斜杠//后的内容不要复制输入

cd ~/lamp
git reset --hard         // Resets the index and working tree
git pull                 // Get latest version first
chmod 755 *.sh

./upgrade.sh             // Select one to upgrade
./upgrade.sh apache      // Upgrade Apache
./upgrade.sh db          // Upgrade MySQL or MariaDB
./upgrade.sh php         // Upgrade PHP
./upgrade.sh phpmyadmin  // Upgrade phpMyAdmin
./upgrade.sh adminer     // Upgrade Adminer

如何卸载

./uninstall.sh 

程序目录

  • MySQL 安装目录: /usr/local/mysql
  • MySQL 数据库目录:/usr/local/mysql/data(默认路径,安装时可更改)
  • MariaDB 安装目录: /usr/local/mariadb
  • MariaDB 数据库目录:/usr/local/mariadb/data(默认路径,安装时可更改)
  • PHP 安装目录: /usr/local/php
  • Apache 安装目录: /usr/local/apache

命令一览

  • MySQL 或 MariaDB 命令
/etc/init.d/mysqld (start|stop|restart|status)
  • Apache 命令
/etc/init.d/httpd (start|stop|restart|status)
  • Memcached 命令(可选安装)
/etc/init.d/memcached (start|stop|restart|status)
  • Redis 命令(可选安装)
/etc/init.d/redis-server (start|stop|restart|status)

网站根目录

默认的网站根目录: /data/www/default

一键安装

系统需求

  • 系统支持

Amazon Linux 2018.03
Amazon Linux 2
CentOS-6.x
CentOS-7.x
CentOS-8.x (recommend)
Debian-8.x
Debian-9.x
Debian-10.x (recommend)
Ubuntu-16.x
Ubuntu-18.x
Ubuntu-20.x (recommend)

  • 内存要求:≥ 512MB
  • 硬盘要求:至少 10GB 以上的剩余空间
  • 服务器必须配置好 软件源 和 可连接外网
  • 必须具有系统 root 权限
  • 强烈建议使用全新系统来安装

支持组件

  • 支持 PHP 自带几乎所有组件
  • 支持 SQLite、MySQL、MariaDB 数据库
  • 支持 Yaf(可选安装)
  • 支持 Redis(可选安装)
  • 支持 XCache (可选安装)
  • 支持 Swoole (可选安装)
  • 支持 Memcached (可选安装)
  • 支持 ImageMagick (可选安装)
  • 支持 GraphicsMagick (可选安装)
  • 支持 ionCube Loader (可选安装)
  • 自助升级 Apache,PHP,phpMyAdmin,Adminer,MySQL/MariaDB 至最新版本
  • 命令行新增虚拟主机(使用 lamp 命令),操作简便
  • 支持一键卸载程序(不会删除网站数据)

安装步骤

  1. 事前准备(安装 wget、git)

注意:双斜杠//后的内容不要复制输入

yum -y install wget git      // for Amazon Linux/CentOS
apt-get -y install wget git  // for Debian/Ubuntu
  1. git clone 并赋予脚本执行权限
git clone https://github.com/teddysun/lamp.git
cd lamp
chmod 755 *.sh
  1. 使用自动模式安装
[root@lamp]# ~/lamp/lamp.sh -h

+-------------------------------------------------------------------+
| Auto Install LAMP(Linux + Apache + MySQL/MariaDB + PHP )          |
| Intro : https://lamp.sh                                           |
| Author: Teddysun <i@teddysun.com>                                 |
+-------------------------------------------------------------------+

Usage: /root/lamp/lamp.sh [Options]...[Parameters]...
Options:
-h, --help                       Print this help text and exit
-v, --version                    Print program version and exit
--apache_option [1-2]            Apache server version
--apache_modules [mod name]      Apache modules: mod_wsgi, mod_security, mod_jk
--db_option [1-9]                Database version
--db_data_path [location]        Database Data Location. for example: /data/db
--db_root_pwd [password]         Database root password. for example: lamp.sh
--php_option [1-8]               PHP version
--php_extensions [ext name]      PHP extensions: 
                                 ioncube, xcache, imagick, gmagick, memcached,
                                 redis, mongodb, libsodium, swoole, yaf, xdebug
--db_manage_modules [mod name]   Database management modules: phpmyadmin, adminer
--kodexplorer_option [1-2]       KodExplorer version

Parameters:
--apache_option [1-2], please select a available Apache version
  1. httpd-2.4.43
  2. do_not_install
--db_option [1-9], please select a available Database version
  1. mysql-5.6.49
  2. mysql-5.7.31
  3. mysql-8.0.21
  4. mariadb-10.1.45
  5. mariadb-10.2.32
  6. mariadb-10.3.23
  7. mariadb-10.4.13
  8. mariadb-10.5.4
  9. do_not_install
--php_option [1-8], please select a available PHP version
  1. php-5.6.40
  2. php-7.0.33
  3. php-7.1.33
  4. php-7.2.34
  5. php-7.3.25
  6. php-7.4.13
  7. php-8.0.0
  8. do_not_install
--kodexplorer_option [1-2], please select a available KodExplorer version
  1. kodexplorer-4.35
  2. do_not_install

比如:安装 Apache、Apache 模块 mod_wsgi,mod_security、MySQL-5.7、root 密码 teddysun.com、PHP-7.2、PHP 扩展 ioncube,imagick,redis,mongodb,libsodium,swoole、phpMyAdmin、Adminer、KodExplorer

~/lamp/lamp.sh --apache_option 1 --apache_modules mod_wsgi,mod_security --db_option 2 --db_root_pwd teddysun.com --php_option 4 --php_extensions ioncube,imagick,redis,mongodb,libsodium,swoole --db_manage_modules phpmyadmin,adminer --kodexplorer_option 1

使用自动模式在安装时,会显示安装选项,比如上面的示例,会返回如下结果,这些信息会记入安装日志:

------------------------- Install Overview --------------------------

Apache: httpd-2.4.43
Apache Location: /usr/local/apache
Apache Additional Modules:
mod_wsgi-4.7.1
modsecurity-2.9.3

Database: mysql-5.7.31
MySQL Location: /usr/local/mysql
MySQL Data Location: /usr/local/mysql/data
MySQL Root Password: teddysun.com

Database Management Modules:
phpMyAdmin-4.9.5-all-languages
adminer-4.7.7

PHP: php-7.2.32
PHP Location: /usr/local/php
PHP Additional Extensions:
ioncube_loaders
imagick-3.4.4
redis-5.3.1
mongodb-1.7.5
libsodium-php-2.0.22
swoole-4.5.2

KodExplorer: kodfile-4.35
KodExplorer Location: /data/www/default/kod

---------------------------------------------------------------------

参数说明

如果你不想安装或者使用默认值,只需将对应的参数省略即可。
数据库的数据位置默认为安装目录下的 data 目录;
数据库的默认 root 密码为 lamp.sh
比如:安装 Apache、MariaDB-10.3、PHP-7.3、phpMyAdmin

~/lamp/lamp.sh --apache_option 1 --db_option 6 --php_option 5 --db_manage_modules phpmyadmin

上面的示例,会返回如下结果:

------------------------- Install Overview --------------------------

Apache: httpd-2.4.43
Apache Location: /usr/local/apache

Database: mariadb-10.3.23
MariaDB Location: /usr/local/mariadb
MariaDB Data Location: /usr/local/mariadb/data
MariaDB Root Password: lamp.sh

Database Management Modules:
phpMyAdmin-4.9.5-all-languages

PHP: php-7.3.20
PHP Location: /usr/local/php

KodExplorer: do_not_install

---------------------------------------------------------------------

使用提示

lamp add      创建虚拟主机
lamp del      删除虚拟主机
lamp list     列出虚拟主机
lamp version  显示当前版本

如何升级

注意:双斜杠//后的内容不要复制输入

cd ~/lamp
git reset --hard         // Resets the index and working tree
git pull                 // Get latest version first
chmod 755 *.sh

./upgrade.sh             // Select one to upgrade
./upgrade.sh apache      // Upgrade Apache
./upgrade.sh db          // Upgrade MySQL or MariaDB
./upgrade.sh php         // Upgrade PHP
./upgrade.sh phpmyadmin  // Upgrade phpMyAdmin
./upgrade.sh adminer     // Upgrade Adminer

如何卸载

./uninstall.sh 

程序目录

  • MySQL 安装目录: /usr/local/mysql
  • MySQL 数据库目录:/usr/local/mysql/data(默认路径,安装时可更改)
  • MariaDB 安装目录: /usr/local/mariadb
  • MariaDB 数据库目录:/usr/local/mariadb/data(默认路径,安装时可更改)
  • PHP 安装目录: /usr/local/php
  • Apache 安装目录: /usr/local/apache

命令一览

  • MySQL 或 MariaDB 命令
/etc/init.d/mysqld (start|stop|restart|status)
  • Apache 命令
/etc/init.d/httpd (start|stop|restart|status)
  • Memcached 命令(可选安装)
/etc/init.d/memcached (start|stop|restart|status)
  • Redis 命令(可选安装)
/etc/init.d/redis-server (start|stop|restart|status)

网站根目录

默认的网站根目录: /data/www/default

暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇